Dansk Regneark Forum
  Hjælp Hjælp  Søg i forum   Opret ny bruger Opret ny bruger  Log ind Log ind


Fjern tomme celler

 Besvar Besvar
Forfatter
Skemalægger Se dropdown
Bronze bruger
Bronze bruger


Medlem: 27-10-2013
Land: Danmark
Status: Offline
Point: 77
Indlæg funktioner Indlæg funktioner   Tak (0) Tak(0)   Citér Skemalægger Citér  BesvarSvar Direkte Link til dette indlæg Emne: Fjern tomme celler
    Sendt: 05-02-2019 kl. 15:28
Hej,

Den må næsten være svaret herinde før, men kan ikke lige finde den:

Uden VBA: Fra en kolonne med skal udtrækkes data, men kun fra de linier, der har indhold. Samles i den næste kolonne.
Altså

A     skal blive til    A
B B
C
C D
D E
F
F

Jeg har 30 linier, der skal trækkes data fra.
Det skal iøvrigt bruges til en liste til betinget opslag, så der ikke figurerer tomme linier i frop down menuen
Jeg har fundet div engelske løsninger, men kan ikke få det til at fungere i min danske udgave.

Mvh SkemaLægger
Til top



Til top
Mads32 Se dropdown
Sølv bruger
Sølv bruger
Avatar

Medlem: 26-02-2016
Land: Danmark
Status: Offline
Point: 417
Indlæg funktioner Indlæg funktioner   Tak (0) Tak(0)   Citér Mads32 Citér  BesvarSvar Direkte Link til dette indlæg Sendt: 08-02-2019 kl. 19:04
Hej

Her er vedlagt et lille eksempel på hvordan det kan gøres

Til top
Skemalægger Se dropdown
Bronze bruger
Bronze bruger


Medlem: 27-10-2013
Land: Danmark
Status: Offline
Point: 77
Indlæg funktioner Indlæg funktioner   Tak (0) Tak(0)   Citér Skemalægger Citér  BesvarSvar Direkte Link til dette indlæg Sendt: 08-02-2019 kl. 19:19
Tak skal du have, filterfunktionen kender jeg. Jeg kunne godt tænke mig en formel, så det sker løbende. Altså så opslagslisten ændres i takt med at emner fjernes. 

Mvh Mikkel
Til top
rassten Se dropdown
Guld bruger
Guld bruger


Medlem: 26-10-2010
Status: Offline
Point: 694
Indlæg funktioner Indlæg funktioner   Tak (1) Tak(1)   Citér rassten Citér  BesvarSvar Direkte Link til dette indlæg Sendt: 08-02-2019 kl. 23:01
=HVIS.FEJL(INDEKS($A$1:$A$30;MINDSTE(HVIS(ER.TOM($A$1:$A$30);"";RÆKKE($A$1:$A$30)-MIN(RÆKKE($A$1:$A$30))+1);RÆKKE(A1)));"")

der skal trykkes Ctrl+Shift+enter
så trækkes formel ned
VH rassten

Arbejde excel 2010
Privat excel 2010
Til top
Skemalægger Se dropdown
Bronze bruger
Bronze bruger


Medlem: 27-10-2013
Land: Danmark
Status: Offline
Point: 77
Indlæg funktioner Indlæg funktioner   Tak (0) Tak(0)   Citér Skemalægger Citér  BesvarSvar Direkte Link til dette indlæg Sendt: 09-02-2019 kl. 23:24
Det duer!
Dog med en lille rettelse, idet cellerne faktisk ikke er tomme, men indeholder en formel. Derfor i stedet

=HVIS.FEJL(INDEKS($N$1:$N$33;MINDSTE(HVIS(($N$1:$N$33)=".";"";RÆKKE($N$1:$N$33)-MIN(RÆKKE($N$1:$N$33))+1);RÆKKE(N2)));"")

Idet jeg har sat formlen til at lave en prik i de linier, der ikke skal medtages. Kan formentlig skiftes til "".
(og så arbejder jeg på kolonne N)

Problem Solved!
Tak.
Til top
 Besvar Besvar
  Del emne   

Skift forum Forum tilladelser Se dropdown

© 2010 - 2019 Dansk Regneark Forum - en del af Excel-regneark.dk