Dansk Regneark Forum
  Hjælp Hjælp  Søg i forum   Opret ny bruger Opret ny bruger  Log ind Log ind


Emne lukketLandekoder til landenavne

 Besvar Besvar
Forfatter
cprdk Se dropdown
Forum Begynder
Forum Begynder
Avatar

Medlem: 08.Jan.2018
Land: Danmark
Status: Offline
Point: 5
Direkte link til dette indlæg Emne: Landekoder til landenavne
    Sendt: 05.Mar.2021 kl. 14:46
Hej,
Jeg har et problem. I kolonne A har jeg en masse e-mail adresser (en for hver række). Disse e-mails har en anden slutning (. dk,.co.uk,. ru,. it osv).
Jeg vil i kolonne B indsætte navnet på det relevante land, så hvis e-mailen ender med. dk, det skriver ′′ Danmark ′′ i kolonne C, hvis e-mailen ender med. fr, det vil skrive ′′ Frankrig ′′ i kolonne C. Landet skal være i en celle i samme række som e-mailen.
Problemet er ikke at bestemme landet (hvis. dk er Danmark, hvis. det er Italien osv), men det er bare med at have en formular, der giver mig det korrekte land for de relevante e-mails.
Hvordan løser man dette? Tak på forhånd.
Til top



Til top
Hans K. Se dropdown
Guld bruger
Guld bruger


Medlem: 04.Apr.2019
Land: Danmark
Status: Online
Point: 967
Direkte link til dette indlæg Sendt: 05.Mar.2021 kl. 15:41
Er det sådan?

Til top
cprdk Se dropdown
Forum Begynder
Forum Begynder
Avatar

Medlem: 08.Jan.2018
Land: Danmark
Status: Offline
Point: 5
Direkte link til dette indlæg Sendt: 05.Mar.2021 kl. 17:02
Hej Hans

Lige præcist

Har du alle lande ?

Bedste hilsner

Claes
Til top
Hans K. Se dropdown
Guld bruger
Guld bruger


Medlem: 04.Apr.2019
Land: Danmark
Status: Online
Point: 967
Direkte link til dette indlæg Sendt: 05.Mar.2021 kl. 17:45
De skulle være i Sheet2.
Til top
Ib Hansen Se dropdown
Guld bruger
Guld bruger
Avatar

Medlem: 15.Apr.2014
Land: Danmark
Status: Offline
Point: 652
Direkte link til dette indlæg Sendt: 06.Mar.2021 kl. 08:36
Hej Hans K.
Super god kode i kolonne B, der henviser til alle landene på Sheet2 Thumbs Up

Men den har en lille fejl, der er hurtig at rette, hvis man har et område man vil kopiere den til, uden der er skrevet en mailadresse i kolonne A.

Den vil lave fejlmeldingen #I/T i kolonne B, ud for de rækker i A, hvor der ikke er en mailadresse.
=INDEKS(Country;SAMMENLIGN(HØJRE(A4;2);CountryCode;0))

claes.
Hvis du har et område, f.eks. A1-A50, der ikke er helt udfyldt med mailadresser i A, men som du vil udfylde efterhånden som du får en ny.
  • Du kan tilføje =HVIS.FEJL( i starten af koden.
  • Og ;"") i slutningen af koden.
Så undgår du fejlmeldingen i B, hvis der ikke er skrevet en mailadressen i A.
Se nedenunder.

Og husk at A4 i koden nedenunder, henviser til den skal være i række 4 (B4), da koden kigger på mailadressen i A4.
(Men den kan stå i hvilken som helst kolonne du ønsker, da den altid vil kigge på mailadressen i A4).

Herefter kan du kopiere/indsætte koden til alle de celler i B, du ønsker.
=INDEKS(Country;SAMMENLIGN(HØJRE(A4;2);CountryCode;0))

=HVIS.FEJL(INDEKS(Country;SAMMENLIGN(HØJRE(A4;2);CountryCode;0));"")

Excel 2010 Dk og 2019 Dk på samme computer.
Bruger dog stadig mest 2010..
Men sådan er der jo så majet :o)
Til top
Hans K. Se dropdown
Guld bruger
Guld bruger


Medlem: 04.Apr.2019
Land: Danmark
Status: Online
Point: 967
Direkte link til dette indlæg Sendt: 08.Mar.2021 kl. 16:44
@cprdk

Fik du svar på det du spurgte om?
Til top
 Besvar Besvar

Skift forum Forum tilladelser Se dropdown

© 2010 - 2022 Dansk Regneark Forum - en del af Excel-regneark.dk